Ruta: La aplicación Farmatic
Resumen: Presentación general de Farmatic y de su núcleo básico (ventas, pedidos, recepción, facturación de recetas). Es un tema contenedor de subtemas sobre el entorno, menús, ventanas, teclas, botones y utilidades generales.
Palabras clave: introducción, qué es farmatic, programa de gestión de farmacia, procesos básicos, entorno, menús, teclas, botones, ayuda general
Preguntas típicas: ¿Qué es Farmatic y qué procesos incluye? | ¿Dónde encuentro información general sobre el manejo del programa?
FARMATIC es una aplicación orientada a la informatización de oficinas de farmacia, independientemente de su volumen de venta, pues contempla desde las mínimas necesidades del trabajo diario cotidiano hasta las más amplias exigencias en cuanto a elaboración y explotación de la información.
El núcleo básico de la aplicación está compuesto por los procesos que usualmente se realizan a diario en la oficina de farmacia:
Ventas
Pedidos
Recepción de mercancías
Facturación de recetas
Íntimamente ligados a la dispensación se encuentran todos los procesos necesarios para poder efectuar una completa explotación de la base de datos suministrada por el Consejo General de Colegios Oficiales de Farmacéuticos.
Asimismo, se dispone de todos los procesos necesarios para poder llevar un riguroso control de caja, así como de las gestiones relacionadas con clientes.
Del trabajo habitual en la farmacia se irán desprendiendo el resto de datos que posteriormente, cuando el usuario precise de ellos, podrá explotar a través de los diversos procesos complementarios que la aplicación presenta: Estadísticas, inventarios, contabilidad, históricos, herramientas de marketing, cuadros de mandos, planes de incentivos, etc.
Ruta: La aplicación Farmatic > El entorno de Farmatic
Resumen: Explica la pantalla principal de Farmatic: menús, barra de herramientas, imagen de fondo, tamaño y posición de ventanas y diferencia entre ventanas modales y no modales. Ruta: La aplicación Farmatic > El entorno de Farmatic.
Palabras clave: pantalla principal, imagen de fondo, bitmap, guardar posición y tamaño de las ventanas, ventana modal, ventana no modal, minimizar ventana, varias ventanas abiertas, configuración general
Preguntas típicas: ¿Cómo pongo una imagen de fondo en Farmatic? | ¿Cómo hago que las ventanas recuerden su tamaño y posición? | ¿Qué diferencia hay entre ventanas modales y no modales?
La aplicación FARMATIC está totalmente adaptada al entorno gráfico de Windows, siendo su manejo en cuanto a operatorias estándar muy similar a cualquier otra aplicación integrada en dicho entorno.
Así pues, al entrar en la aplicación se presenta una pantalla en la que, en su parte superior, figuran los menús desplegables principales, así como una barra de herramientas en la que se dispone de acceso directo a los puntos y acciones básicas disponibles. Esta barra puede ser omitida si así se desea.
Como fondo de esta ventana inicial de acceso a la aplicación se puede utilizar cualquier imagen que se desee. Para ello, en el entorno Configuración General (de cada puesto) en el proceso CONFIGURACIÓN/PARÁMETROS se dispone del parámetro "Imagen de fondo (Bitmap) para ventana", donde se debe indicar la imagen a utilizar. La misma será repetida tantas veces como sea posible en la ventana principal de inicio de FARMATIC. Recuérdese que dicha imagen debe corresponderse a un fichero de extensión BMP.
FARMATIC, como cualquier aplicación Windows, presenta un entorno de ventanas, pudiendo haber varias de ellas abiertas, lo que facilita al usuario simultanear procesos, consultas paralelas, etc. Dichas ventanas pueden ser dimensionadas por el propio usuario fácilmente con la ayuda del ratón, adaptando su tamaño y ubicación en pantalla a las necesidades de cada momento. Será optativo que los cambios de tamaño y ubicación de una ventana queden grabados de forma que al volver a abrir en lo sucesivo dicha ventana se haga con el tamaño y ubicación con que se cerró por última vez. La indicación sobre si se desea dejar fijados tamaño y ubicación de las ventanas se realizará desde el proceso CONFIGURACIÓN / PARÁMETROS de la aplicación (concretamente mediante el parámetro "Guardar posición y tamaño de las ventanas" del apartado Configuración General).
Ahora bien, se debe diferenciar entre dos tipos de ventanas:
No Modal : La mayoría de las ventanas de la aplicación corresponden a este tipo, cuyas características son el poder convivir con otras ventanas, pudiéndose realizar otros procesos aunque dicha ventana esté abierta. Asimismo, este tipo de ventanas puede disponer de diferentes botones que permiten realizar acciones específicas del proceso al que la ventana corresponde. Por ejemplo, editar un registro, borrarlo, etc. Son ventanas de este tipo las correspondientes, por ejemplo, a ventas mostrador, alta de vendedores, artículos, etc. Estas ventanas pueden ser minimizadas, si así se desea.
Modal : Este tipo de ventanas, por estar ligadas a acciones que se considera no deben convivir con otros procesos, se caracteriza por el hecho de que mientras está abierta no se tiene acceso a ningún otro punto de la aplicación ni a ninguna otra ventana que pudiera estar abierta con anterioridad. Podrá observarse que el icono de minimización está inhabilitado, es decir, no pueden minimizarse pues no ha lugar si no se va a permitir ninguna otra acción mientras esté abierta. Asimismo, no presentan más botones de acceso directo que los de Aceptar y Cancelar, de forma que cualquier acción que se deba realizar desde ellas se deberá ejecutar haciendo uso de las teclas de acceso directo correspondientes o haciendo clic con el botón derecho del ratón para abrir el selector de opciones disponibles donde se elegirá la deseada. Un ejemplo de este tipo de ventana es la correspondiente al proceso de definición de familias, pues se considera que mientras se están realizando modificaciones en las mismas no es conveniente trabajar en otros puntos de la aplicación donde ello podría tener repercusiones no deseadas. Otro ejemplo significativo de este tipo de ventana se encuentra en el proceso de definición de parámetros y configuración de la aplicación.
En el caso de tener abiertas varias ventanas simultáneamente (obviamente, ventanas no modales), para acceder a una de ellas en concreto basta con pinchar con el ratón en algún punto de dicha ventana, pasando ésta al frente automáticamente. Según lo anteriormente expuesto este comportamiento no es aplicable cuando se esté manejando una ventana modal, que deberá cerrarse si se desea acceder a otra ventana diferente.
Las ventanas pueden presentar en su parte superior derecha uno o varios botones característicos que deben conocerse:
Minimizar Ventana : Permite dejar la ventana en su estado más reducido, de forma que no se presenta en pantalla pero no se ha cerrado, lo que permite poder recuperarla en cualquier momento pinchando sobre el botón Maximizar o el botón Restaurar. Como ya se ha comentado, este botón estará inhabilitado cuando se trate de una ventana modal.
Maximizar Ventana : Permite dejar la ventana en su máximo tamaño, es decir, ocupación completa de la pantalla. Este botón estará disponible siempre que la ventana presente su tamaño original o esté minimizada.
Restaurar Ventana : Permite retornar la ventana a su tamaño original. Este botón estará disponible siempre y cuando la ventana esté maximizada o minimizada.
Cerrar Ventana : Permite cerrar por completo la ventana, dándose por finalizado el proceso al que corresponde.
Si debido al tamaño de la ventana no es posible visualizar por completo su contenido, se presentarán sendas barras de desplazamiento en su margen inferior y en su margen derecho. Estas barras permitirán ir desplazando en sentido horizontal y/o vertical el contenido de la ventana, a fin de poder visualizar todos los datos. Este desplazamiento podrá realizarse bien pinchando con el ratón en los extremos de las barras o pinchando y desplazando sin soltar el botón de desplazamiento.
A continuación se incluye un ejemplo de ventana con barras de desplazamiento:
En cada ventana se dispondrá de los elementos específicos necesarios para su manejo: Botones de comandos básicos, teclas de acceso directo, etc., habiéndose seguido al respecto un criterio generalizado en todos los puntos de la aplicación.
En algunos puntos de la aplicación mediante la pulsación del botón derecho del ratón se tendrá acceso a una serie de opciones disponibles, que podrán ser diferentes en función del punto en el que se haya realizado esta acción. Si se dispone de un teclado de los denominados comúnmente "Microsoft Natural Keyboard", que presentan una tecla que equivale a la pulsación del botón derecho del ratón, al pulsar dicha tecla en FARMATIC se mostrará el menú contextual apropiado.
Del mismo modo, si de dispone de ratón "mousewheel" con rueda central, de instalarse el manejador adecuado, dicha rueda simulará las funciones de scroll.
De otra parte, se permite aplicar zoom sobre la ventana en la que se está trabajando. Es decir, ampliar o reducir su tamaño de visualización en ese momento. La ampliación, reducción o restauración de tamaño origianal se pueden realizar de varias formas:
Desde el menú VENTANA / ZOOM
Con el ratón, rodando la rueda manteniendo pulsada la tecla
Vía teclado
Cuando se aplica zoom, momentáneamente se informa del porcentaje de aumento o disminución aplicado, y se ofrece la posibilidad de restablecer el tamaño original (zoom 100%).
También se tiene la posibilidad de ocultar el marco de la ventana principal de Farmatic. Para ocultarlo, activar la opción VENTANA COMPLETA en el menú VENTANA, o pulsar
Por último indicar que el color de presentación de las cabeceras de las parrillas de datos podrá ser elegido por el usuario en el entorno CONFIGURACIÓN GENERAL del proceso CONFIGURACIÓN / PARÁMETROS.
Ruta: La aplicación Farmatic > Estilos de interfaz
Resumen: Permite elegir entre interfaz Moderno o Clásico y botones grandes o pequeños. Se configura en Configuración/Parámetros > Configuración general (Estilo interfaz) y en Ver > Barra de herramientas > Botones grandes.
Palabras clave: estilo interfaz, moderno, clásico, iconos grandes, iconos pequeños, botones grandes, apariencia, cambiar aspecto del programa
Preguntas típicas: ¿Cómo cambio el aspecto de los iconos entre moderno y clásico? | ¿Cómo pongo los botones más grandes?
Se permite elegir entre dos estilos de interfaz: Moderno o Clásico. Los iconos de las diferentes barras de herramientas serán diferentes en uno y otro.
Barra principal en interfaz Moderno:
Barra principal en interfaz Clásico:
La elección del estilo de interfaz, Moderno o Clásico, se establece en el parámetro APARIENCIA GENERAL.- Estilo interfaz, ubicado en el entorno CONFIGURACIÓN GENERAL del proceso CONFIGURACIÓN / PARÁMETROS.
En ambos estilos, se puede optar por la visualización de botones en dos tamaños, grandes o pequeños, según se active o no la opción VER / BARRA DE HERRAMIENTAS / BOTONES GRANDES.
Ahora bien, en formato moderno el cambio afectará a los iconos de todas las ventanas. En el formato clásico, el tamaño solamente variará en la barra principal de la aplicación.
Por defecto, en resoluciones superiores a 1024, se mostrarán botones grandes.
Iconos grandes en interfaz Moderno:
Iconos pequeños en interfaz Moderno:
Iconos grandes en interfaz Clásico:
Iconos pequeños en interfaz Clásico:
Ruta: La aplicación Farmatic > Los menús de la aplicación
Resumen: Describe los menús principales (Maestros, Ventas, Compras, Informes, Contabilidad, Utilidades, Archivo, Edición, Ver, Ventana, ?) y cómo seleccionar opciones con ratón, teclado o letras de acceso. Contenedor de los subtemas de cada menú.
Palabras clave: menú principal, maestros, ventas, compras, informes, contabilidad, utilidades, alt letra de acceso, opciones apagadas, opciones activables
Preguntas típicas: ¿Qué menús tiene Farmatic? | ¿Cómo accedo a un menú con el teclado? | ¿Por qué algunas opciones del menú aparecen apagadas?
En la pantalla principal de la aplicación, a la que se accede directamente al entrar en ella, se presenta la barra de menús principales disponibles:
Dichos menús pueden clasificarse en dos grupos:
. MAESTROS
. VENTAS
. COMPRAS
. INFORMES
. CONTABILIDAD
. UTILIDADES
. ARCHIVO
. EDICIÓN
. VER
. VENTANA
. ? (Acceso a las ayudas y procesos relacionados con servicios proporcionados por Consoft)
Todos los menús mencionados presentan a su vez una serie de opciones, que pueden visualizarse desplegando el menú correspondiente. Asimismo, algunas de las opciones que se presentan una vez desplegado un menú pueden englobar varias subopciones. Las opciones que disponen de subopciones aparecerán señaladas mediante un icono en forma de punta de flecha.
Debe tenerse en cuenta que no siempre estarán disponibles todas las opciones de un menú, pues ello dependerá del punto desde el que se haya accedido al mismo. Las opciones disponibles aparecerán "encendidas" y las opciones no disponibles en este momento aparecerán "apagadas".
Por último indicar que algunas opciones representan un acceso a un proceso o acción en concreto, mientras que otras tienen como finalidad la activación o desactivación de un elemento o propiedad de entorno. En este último caso, las opciones activas aparecerán precedidas de una marca característica.
Para seleccionar una opción de acceso a un proceso se dispone de varias alternativas:
Hacer clic con el botón izquierdo del ratón sobre el menú desplegable en el que se engloba y a continuación volviendo a hacer clic sobre dicho proceso en cuestión. Esta misma operatoria puede seguirse utilizando el teclado en vez del ratón, debiéndose entonces utilizar las flechas del teclado para situarse sobre la opción deseada y pulsar
En aquellos procesos que tienen un acceso directo, bastará con pinchar con el botón izquierdo del ratón sobre el botón de acceso correspondiente.
En aquellos procesos que tienen una letra de acceso, la misma aparecerá subrayada en el nombre del proceso. Si se trata de un menú principal, se podrá acceder a ellos pulsando simultáneamente las teclas
En el caso de tratarse de una opción de activación/desactivación, la operatoria a seguir es la siguiente: Pinchar con el botón izquierdo del ratón sobre la opción en cuestión. Si estaba desactivada se activará, apareciendo la marca característica mencionada. Si, por el contrario, la opción estaba ya activa, se desactivará, desapareciendo dicha marca. El mismo efecto surtirá si en vez de utilizarse el ratón se utilizan las flechas del teclado para situarse sobre la opción en cuestión y se pulsa
Por último, indicar que se permite elegir el estilo de visualización de los menús. En VER / BARRA DE HERRAMIENTAS / MENÚS se dispone de varios estilos de visualización, a semejanza de los utilizados en diferentes versiones de Windows y MS Office.
Ruta: La aplicación Farmatic > Los menús de la aplicación > La barra de herramientas
Resumen: Explica la barra de herramientas principal y las de cada ventana, con botones de acceso directo y textos descriptivos al pasar el ratón. Formatos Moderno y Clásico.
Palabras clave: barra de herramientas, botones de acceso directo, iconos, barra principal, botón apagado, tooltip
Preguntas típicas: ¿Para qué sirve la barra de herramientas? | ¿Por qué algunos botones aparecen deshabilitados?
Gran número de procesos y acciones disponibles en la aplicación disponen de un botón de acceso directo, bastando pinchar sobre el mismo con el ratón para activar dicho proceso o realizar la acción deseada.
Por lo general estos botones se encuentran agrupados en la parte superior de cada ventana, conformando lo que se dará en llamar una barra de herramientas, si bien se encontrarán también botones ubicados en otros puntos de las ventanas donde sea conveniente su utilización.
En la pantalla principal de FARMATIC, a la que se accede directamente al entrar en la aplicación, se encuentra la barra principal de herramientas, en la que se agrupan los accesos directos a los menús principales de la aplicación.
BARRA PRINCIPAL DE HERRAMIENTAS FORMATO MODERNO:
BARRA PRINCIPAL DE HERRAMIENTAS FORMATO CLÁSICO :
Situando el cursor del ratón momentáneamente sobre cualquier botón de la barra de herramientas se visualizará un breve texto descriptivo sobre la finalidad de dicho botón, de forma que se facilite al usuario la identificación del mismo. Haciendo clic con el botón izquierdo del ratón sobre un botón de la barra de herramientas se accederá al proceso en cuestión o se ejecutará la acción correspondiente.
Debe tenerse en cuenta que en las barras de herramientas de las ventanas correspondientes a los procesos no siempre aparecerán disponibles ("encendidos") todos los botones, pues dependerá de la información presente en dicha ventana. Por ejemplo, puede no presentarse activo un botón de borrar un registro si en la ventana no se ha visualizado aún ningún registro de información.
Ruta: La aplicación Farmatic > Los menús de la aplicación > El menú Archivo
Resumen: Opciones del menú Archivo: Nuevo, Editar, Guardar, Borrar, Seleccionar impresora, Imprimir ventana y Utilidades (modificación de artículos por lista, inventario, SACS, mínimos y máximos...), con sus teclas rápidas.
Palabras clave: nuevo, editar, guardar, borrar, seleccionar impresora, imprimir ventana, cambiar impresora, utilidades de artículos, alt+a, ctrl+insert, f10
Preguntas típicas: ¿Cómo cambio la impresora para albaranes o facturas? | ¿Qué utilidades hay en el menú Archivo? | ¿Cuál es la tecla para guardar o crear un registro nuevo?
Uno de los menús principales de la aplicación es el menú ARCHIVO al que se puede acceder pinchando sobre él con el botón izquierdo del ratón o pulsando directamente las teclas
NUEVO : Acceso directo mediante la pulsación de
EDITAR : Acceso directo mediante la pulsación de
GUARDAR : Acceso directo mediante la pulsación de
BORRAR : Acceso directo mediante la pulsación de
SELECCIONAR IMPRESORA : Permite el acceso al proceso de selección y configuración de impresora de Windows, desde donde se podrá seleccionar el tipo de papel, orientación del mismo, número de copias a imprimir, etc. Además, tras aceptar en esta primera ventana, se presentará una segunda ventana donde activar los entornos en los que se ha de aplicar ese cambio de impresora: impresora de uso general, impresora de albaranes de venta, de facturas de contado en ventas, de presupuestos en ventas y/o de facturas de crédito. Esta opción tiene acceso directo mediante el botón Seleccionar/Configurar Impresora de la barra principal de herramientas.
IMPRIMIR VENTANA : Acceso directo mediante la pulsación de . Mediante esta opción se obtendrá por impresora un volcado de la ventana activa en el momento de la ejecución. Tiene acceso directo mediante el botón Imprime Ventana Activa de la barra principal de herramientas.
UTILIDADES : Permite el acceso de procesos auxiliares de la aplicación FARMATIC, que se consideran de uso esporádico. Estos procesos son:
. Utilidades de Artículos -> Modificación de artículos mediante lista (ver tema).
. Utilidades de Artículos -> Modificación manual de estadísticas (ver tema)
. Utilidades de Artículos ->Edición de inventario (ver tema)
. Utilidades de Artículos -> Sistema Automatizado de Control de Stock (S.A.C.S.) (ver tema)
. Utilidades de Artículos -> Asignación de mínimos y máximos (ver tema: Asignación de máximos y mínimos).
. Utilidades de Artículos -> Asignación de tipos impositivos según familias (ver tema).
. Utilidades de Artículos -> Asignación de familias según grupos terapéuticos (ver tema)
. Utilidades de Artículos -> Definición de grupos genéricos/Acuerdo de precios máximos (ver tema: Definición de grupos genéricos)
. Utilidades de Artículos -> Análisis de cambios de precios (ver tema)
. Utilidades de Artículos -> Cálculo de PVP (ver tema)
. Utilidades de Artículos -> Actualización de PVP desde CGCOF (ver tema: Actualización de PVPs/serializables desde CGCOF)
. Utilidades de Artículos -> Actualización de artículos desde CGCOF (ver tema)
. Utilidades de Clientes -> Modificación de clientes mediante lista (ver tema)
. Utilidades de Ventas -> Asignación de cajas por Vendedor y Máquina (ver tema)
. Utilidades de Ventas -> Asignación de bloques de recetas por puestos (ver tema)
. Utilidades de Ventas -> Registro de líneas eliminadas en ventas (ver tema)
. Utilidades de Ventas -> Medios de Pago (ver tema)
. Utilidades de Proveedor -> Cambio código proveedor (ver tema)
. Importación de ficheros (ver tema)
. Monitor de usuarios activos (ver tema).
. Optimización de Históricos (ver tema).
. Utilidades de Base de Datos (ver tema).
. Mensajes parametrizados (ver tema)
CONFIGURACIÓN/PARÁMETROS (ver tema: Configuración / Parámetros) : Permite adaptar el funcionamiento de la aplicación a las necesidades o preferencias de cada usuario en cuanto al uso y comportamiento de algunos procesos. Asimismo permite indicar qué periféricos se tienen instalados (displays, cajones, etc.) y algunos de los parámetros concernientes a su manejo.
COPIAS DE SEGURIDAD (ver tema) : Permite realizar copias de la base de datos con la que trabaja la aplicación y que contiene los datos de usuario que se han ido generando. De esta forma, ante un imprevisto que provoque pérdida o deterioro de la información se podrá recurrir a recuperar los datos de una copia de seguridad.
CERRAR : Permite abandonar y cerrar la aplicación FARMATIC. Acceso directo mediante el botón Cerrar de la barra principal de herramientas. Si en el momento del cierre de la aplicación se hallase alguna ventana abierta, se avisaría de ello indicándose que la información no guardada se perderá, y se pedirá conformidad para cerrar la aplicación. En el caso de que al cerrar la aplicación no hubiese ninguna ventana abierta, simplemente se pediría conformidad para abandonar FARMATIC.
Obviamente algunas de estas opciones aparecerán inoperantes si se ha desplegado el menú ARCHIVO desde un punto desde el que no ha lugar la acción a la que corresponden.
Ruta: La aplicación Farmatic > Los menús de la aplicación > El menú Edición
Resumen: Opciones del menú Edición: Cancelar, Seleccionar todo e Invertir selección, útiles en parrillas y carteras.
Palabras clave: cancelar cambios, seleccionar todo, invertir selección, ctrl+a, f9, selección múltiple, alt+d
Preguntas típicas: ¿Cómo selecciono todas las líneas de una cartera? | ¿Cómo cancelo los cambios hechos en una ventana?
Uno de los menús principales de la aplicación es el menú EDICIÓN al que se puede acceder pinchando sobre él con el botón izquierdo del ratón o pulsando directamente las teclas
CANCELAR : Acceso directo mediante la pulsación de
SELECCIONAR TODO : Acceso directo mediante la pulsación de
INVERTIR SELECCIÓN : Una vez establecida una selección múltiple de registros, mediante esta opción se podrá activar la selección complementaria. Es decir, las líneas seleccionadas se deseleccionarán y quedarán seleccionadas aquellas que no lo estaban.
Algunas de estas opciones aparecerán inoperantes si se ha desplegado el menú EDICIÓN desde un punto desde el que no ha lugar la acción a la que corresponden.